EtchMaster™ Professional Software User Guide

EDWARD PRYOR & SON LIMITED
EGERTON STREET
SHEFFIELD
S1 4JX

Telephone No. - 0114 276 6044
Facsimile No. - 0114 276 6890
www.pryormarking.com
EC DECLARATION OF CONFORMITY

DESCRIPTION OF MACHINERY: ETCHMASTER USB

SERIAL NUMBER:

----------------------------------------

THIS MACHINE COMPLIES WITH THE FOLLOWING DIRECTIVES:

: The machinery Directive 98/37/EC as implemented by The Supply of Machinery (Safety) Regulations 1992 (SI No. 3073) and The Supply of Machinery (Safety) (Amendment) Regulations 1994 (SI No. 2063).


----------------------------------------

THIS MACHINERY AS DESCRIBED IN THIS DECLARATION OF CONFORMITY CONFORMS IN ALL RESPECTS WITH THE ESSENTIAL HEALTH & SAFETY REQUIREMENTS STATED IN THE ABOVE LISTED DIRECTIVES, STANDARDS AND SPECIFICATIONS.

SIGNED

TITLE: MANAGING DIRECTOR

DATE: ............................................

EMPOWERED TO SIGN ON BEHALF OF THE RESPONSIBLE PERSON, MR N. ANDREW, DIRECTOR OF EDWARD PRYOR AND SON LTD. AT THE ABOVE ADDRESS.
Contents

Pryor EtchMaster™ Pro Software User Guide..... 7
System Requirements ......................................................... 7
Executing the software ....................................................... 9
  Desktop Icon ...................................................................... 9
  Start Menu ........................................................................ 9
  Auto Start Feature (Customised systems only) ......................... 9
The EtchMaster™ Professional Views ......................... 11
  Layout Contents ............................................................ 11
  Text Edit View .................................................................. 11
  Navigation ........................................................................ 11
  Properties View .................................................................. 12
  The Graphical View .......................................................... 12
Creating a layout – Quick Start Guide ......................... 20
  Step 1 : Adding Objects for Printing .................................. 20
  Step 2 : Changing EtchMaster USB unit settings .................... 21
Adding Objects to Layouts .............................................. 22
  Creating Objects using the Object Tool Bar ....................... 22
  Creating Objects using the Menu ...................................... 22
The Text Objects ............................................................... 23
  Text Properties ............................................................... 23
  Font ................................................................................. 23
  Is Filled ........................................................................... 23
  Maintain Ratio .................................................................. 23
  Text Alignment .................................................................. 23
  Is Inverted ........................................................................ 24
  Vertical Quiet Zone (mm) .................................................. 24
  Tweaks Properties ........................................................... 24
  Character Angle (deg) ...................................................... 24
  Spacing .......................................................................... 24
  Compression ...................................................................... 24
  Shear .............................................................................. 25
  Position Properties .......................................................... 25
  X (mm) ............................................................................. 25
  Y (mm) ............................................................................. 25
  Width Property ................................................................. 25
  Height Property ............................................................... 25
  Angle (deg) ...................................................................... 25
Arc Text ............................................................................. 27
  Arc Text Properties .......................................................... 27
  Inner Diameter (mm) ........................................................ 27
  Outer Diameter (mm) ......................................................... 27
  Offset (mm) ...................................................................... 27
  Align to Inner Diameter .................................................... 27
The DataMatrix Object ...................................................... 29
  Text ............................................................................... 29
  Static Text ...................................................................... 29
  Dynamic or Variable Text .................................................. 29
  Size Property ..................................................................... 29
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Ratio</td>
<td>29</td>
</tr>
<tr>
<td>Is Inverted</td>
<td>30</td>
</tr>
<tr>
<td>Quiet Zone (mm)</td>
<td>30</td>
</tr>
<tr>
<td>Position Properties</td>
<td>30</td>
</tr>
<tr>
<td>X (mm)</td>
<td>30</td>
</tr>
<tr>
<td>Y (mm)</td>
<td>30</td>
</tr>
<tr>
<td>Width Property</td>
<td>30</td>
</tr>
<tr>
<td>Height Property</td>
<td>30</td>
</tr>
<tr>
<td>Maintain Ratio</td>
<td>30</td>
</tr>
<tr>
<td>Auto Grow</td>
<td>31</td>
</tr>
<tr>
<td>Module Width</td>
<td>31</td>
</tr>
<tr>
<td>Module Height</td>
<td>31</td>
</tr>
<tr>
<td>Angle (deg)</td>
<td>31</td>
</tr>
<tr>
<td><strong>Barcode</strong></td>
<td>33</td>
</tr>
<tr>
<td>Text</td>
<td>33</td>
</tr>
<tr>
<td>Format</td>
<td>33</td>
</tr>
<tr>
<td>Use Check Digit</td>
<td>33</td>
</tr>
<tr>
<td>Bar Width Ratio</td>
<td>33</td>
</tr>
<tr>
<td>Is Inverted</td>
<td>33</td>
</tr>
<tr>
<td>Quiet Zone (mm)</td>
<td>34</td>
</tr>
<tr>
<td>Position Properties</td>
<td>34</td>
</tr>
<tr>
<td>X (mm)</td>
<td>34</td>
</tr>
<tr>
<td>Y (mm)</td>
<td>34</td>
</tr>
<tr>
<td>Width Property</td>
<td>34</td>
</tr>
<tr>
<td>Height Property</td>
<td>34</td>
</tr>
<tr>
<td>Angle (deg)</td>
<td>34</td>
</tr>
<tr>
<td><strong>The Imported Graphics File Object</strong></td>
<td>35</td>
</tr>
<tr>
<td>Is Filled</td>
<td>35</td>
</tr>
<tr>
<td>Position Properties</td>
<td>36</td>
</tr>
<tr>
<td>X (mm)</td>
<td>36</td>
</tr>
<tr>
<td>Y (mm)</td>
<td>36</td>
</tr>
<tr>
<td>Width Property</td>
<td>36</td>
</tr>
<tr>
<td>Height Property</td>
<td>36</td>
</tr>
<tr>
<td>Maintain Ratio</td>
<td>36</td>
</tr>
<tr>
<td>Angle (deg)</td>
<td>36</td>
</tr>
<tr>
<td><strong>Saving and Opening Layouts</strong></td>
<td>37</td>
</tr>
<tr>
<td>Printing a Layout</td>
<td>37</td>
</tr>
<tr>
<td><strong>Variables</strong></td>
<td>39</td>
</tr>
<tr>
<td>Time/Date Variables</td>
<td>40</td>
</tr>
</tbody>
</table>
Pryor EtchMaster™ Professional is a software application designed specifically for Microsoft Windows 2000 and XP. The highly intuitive software is extremely user friendly, yet flexible enough to suit any industrial marking requirements. The software is primarily used to create and print layout inscriptions to any Windows compatible label printer.

System Requirements

The minimum PC requirements to run the EtchMaster software are outlined below.

- 800MHz Pentium (minimum)
- 64 MB or higher
- Windows 2000 or XP
- 10MB Hard Disk free
- 800 x 600 SVGA (minimum resolution)
Executing the software

When EtchMaster Pro is installed, you may run the software by either of the following methods.

**Desktop Icon**
Double click the left mouse button on the EtchMaster Professional icon on the Windows desktop.

**Start Menu**
Click on the Windows Start button then select…
Programs-> EtchMaster Professional-> EtchMaster Professional

**Auto Start Feature** (Customised systems only)
Customised systems have the auto-start feature where the system starts up with the user interface system ready to use.
The EtchMaster™ Professional Views

EtchMaster Professional has 3 distinct views separated by 2 Window splitter bars. The bars can be moved to resize the individual views to suit the users’ preferences. Simply move the cursor over the splitter bar, hold the left mouse button down and drag the bar to the desired position.

Layout Contents

The Layout Contents allows elements of a marking program such as, Text, Datamatrix Codes, Bitmaps, Arc Text, Barcodes, HPGL logo’s, Shapes and Layout Scripts, etc... to be added and their properties to be edited. The Layout Contents also provides a means for sequencing the order of marking and creating advanced marking sequences using the scripting function.

Text Edit View

The EtchMaster Professional text edit view allows markable objects (Text, Datamatrix Codes, Bitmaps etc.) to be created and their basic properties to be edited. This view is useful for creating simple layouts especially if the objects have known positions and sizes. The text edit view also provides a means for font selection, character spacing, height, width and X-Y positioning.

Navigation

This function allows navigation around the graphic view, it works very much like a drawing package navigation window. To operate click on the navigation tab, this will display the contents of the layout enveloped by a blue box, position the cursor in the
area of the blue box, hold down the left mouse button and drag the mouse to move the navigation window. This function is particularly useful when creating large and complex layouts

**Properties View**

The properties view displays the properties of the currently selected object, that could be a piece of text, a barcode or a graphics object. The properties are displayed as edit boxes or drop down boxes which can be modified when the object is selected by the mouse.

**The Graphical View**

The EtchMaster Professional graphical view allows markable objects to be created and manipulated in much the same way as a graphical drawing application. Objects can be selected using the mouse and moved, resized or rotated simply by holding the left button and dragging the mouse. This view is useful for creating complex layouts very quickly, it also serves as an onscreen print preview.
Quick Start Guide-Setting up the Printer and Etcher

Installing the Printer – To install the printer, consult the documentation supplied with the printer. The printer will need to be connected to the PC with its Windows drivers installed for it to be used with EtchMaster.

Once the printer is installed. You need to configure EtchMaster to use the printer. To do this select File -> Edit Active Machine. This will display the screen below.

Under the Machine() setting select the ‘Etching Printer(ETCHMASTER ETHING PRINTER)’ setting, then select the installed printer from the drop down box on the right of the screen. If the printer is not displayed in the drop down box then the printer drivers have not be installed correctly.

Then click the Printer Properties Button to display the settings for the printer.

Pryor supply 2 models of printer these are the TEC B452 and the Zebra TLP3842. Each one is configured differently for stencil printing and are covered separately below.

Configuring the Zebra TLP3842 Printer

When the Printer Properties button is pressed the screen below is displayed.
Expand the Printer/Output setting and configure the Paper Layout, Paper Size, Copies and Rotate 180 to as above.

Then expand the Media Settings.

Set the Media Type as above, select Media Tracking and select Continuous. Then click on the Options button to display the dialog below.
The Advance After Print setting is quite important. It defines how much additional stencil the printer feeds after the printing is complete. When etching it important to feed some additional stencil so the electrode is not in direct contact with the surface to be marked. If the print is too close to the bottom edge of the stencil then increase this value to move it up the stencil.

Set the Reverse Sensor to off.

Then expand the Document Options.

Set the settings as above, then click on the Options button to display the settings below.
Select the Cut Label to After label, this activates the cutter.

Then expand the Device Options and set the related settings as below. The user commands do not need to be configured.

Click OK the default printer settings are not configured.

**Configuring the TEC B452 Printer**

The TEC printer should be configured according to the screens below.
The Etch master professional views
Setting the Printer Settings for individual Layouts

The printer settings that are configured in the Edit Active Machine screen are the default printer settings for all new layouts created. A layout may have its own individual printer settings, by clicking on the Setup... button on the main tool bar of the software when the layout is on screen. This can be useful for setting different stencil sizes for different layouts.

Loading the Stencil Material

The stencil material is similar to die–impression paper with a permeable fabric and a non-permeable laminate. The laminate is thermally removed from the stencil using the thermal printer leaving the image on the permeable fabric. The non-permeable laminate has a shiny finish and should be facing upwards when loaded into either type of printer.

Note: The printer operates in Direct Thermal mode. Therefore no ink rolls are required for this process. Only the stencil roll should be loaded in to the printer for stencil printing.

Note: Load Stencil Material Shiny Side Up.

When the stencil is printed a mirror image of the layout is printed. The stencil should then be flipped and used shiny side down when marking using the Etching device.

Note: It can be difficult to see the printed stencil as there is little contrast between the print and the background stencil. Move the stencil under a light source and the print can then be seen.

Setting up the Etching Device.

The EtchMaster Pro software allows you to configure the settings used on the EtchMaster™ etching device. These include the AC and DC power levels and time periods. When a stencil is printed you can send the settings to the EtchMaster device using its USB connection. To activate this, plug in the EtchMaster™ USB connection to the PC. Windows will detect a new device and request a location for the device drivers. The drivers are located at the following file path.

C:\Program Files\EtchMaster Professional\Drivers\
Once the Driver is installed go to the File->Edit Active Machine screen and select Pryor EtchMaster-USB in the Etching Device tab.
Creating a layout – Quick Start Guide

A layout is a collection of printable objects. To perform any sort of printing a layout must first be created, then printable objects can be added to the layout. A printable object can be some text, a DataMatrix code or an imported graphics file. To create a layout select New from the File menu or Click on the toolbar. A blank layout is displayed ready for editing.

Step 1 : Adding Objects for Printing

First we can start by adding text and graphics into the layout. Text can be positioned into the layout by selecting from the menu Insert->Markable Objects->Text or by clicking on the toolbar button. Each item inserted into the layout is placed in the Marking Sequence within the Layout Contents tab. As shown below.

The properties for the Text may be modified when the Text object is selected by the mouse. For further details on each of the properties see the Text Object section of the manual. The position of the text may be modified by entering the X and Y values directly into the Position tab of the Properties screen or by dragging the text on the graphics view.

Tip : If you have a wheel mouse on your PC you can use it to rapidly zoom in and out of your graphics view. Pressing the wheel in and moving the mouse allows you to grab the graphics view and rapidly scroll the screen. If your system does not have a wheel mouse you can hold down the CTRL key with the right mouse button and move the mouse forward and back to zoom in and out, Holding down the SHIFT key and the right mouse button allows the screen to be scrolled with the mouse movements.
Step 2 : Changing EtchMaster USB unit settings

The layout is now ready to be printed, however if the Pryor EtchMaster USB etching unit is attached to the PC, the etching unit settings such as AC Power level, DC power level, tile periods etc will be set to the default values. It is highly likely that these will need changing to achieve the desired mark quality on the material used.

To change the etching unit settings click on the graphics view away from any objects. This will display the Layout, Etching Settings and Persistence tabs in the properties view. Click on the Etching Settings tab and modify the values to suit the material to be marked.

<table>
<thead>
<tr>
<th>Before DC Delay(s)</th>
<th>0.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>DC Duration(s)</td>
<td>3.00</td>
</tr>
<tr>
<td>DC Voltage</td>
<td>20</td>
</tr>
<tr>
<td>AC Duration(s)</td>
<td>3.00</td>
</tr>
<tr>
<td>AC Voltage</td>
<td>20</td>
</tr>
<tr>
<td>After Mark Delay(s)</td>
<td>0.00</td>
</tr>
</tbody>
</table>

The layout is now ready to be printed. See the Printing Layouts section of the manual for further details.
Adding Objects to Layouts

Objects can be created using either the Object Toolbar or the Insert menu.

Creating Objects using the Object Tool Bar

The Object Toolbar is a quick way to create new objects within the current layout. Some of the more commonly used types of objects and the corresponding toolbar buttons are shown below.

- Creates a Datamatrix Object within the layout.
- Creates a Text Object within the layout.
- Creates an Arc Text Object within the layout.
- Creates a Barcode Object within the layout.
- Creates an Imported Graphics File Object within the layout.
- Creates a Bitmap File Object within the layout.
- Creates a Shape within the layout.

When a new object is created using the toolbar, the object is placed at the next free line in the Layout Contents window. Once an object is placed in the layout it can be edited by selecting that object in the Layout Contents window. The object can also be moved by clicking the object in the Layout Contents window and dragging to change the marking sequence.

Creating Objects using the Menu

The Insert menu contains all the objects for inserting as part of a marking layout. Selecting one of these objects creates that object within the marking layout.
The most commonly used markable object is the Text object. It is used for marking any type of text, be that static text or variable text. The Text object has many editable properties, changing these affects the way a piece of text is displayed and marked. Another commonly used markable object is the Arc. This too, is used for marking any type of text that is to be marked in an arc on a flat workpiece. A full description of each property is given below.

Text Properties

The text properties are located within the Text Object.

Text

The Text Object is located in the Objects Tool Bar and in the Insert tab in the function bar drop down menu. (If the Objects Tool Bar cannot be viewed click on View>Toolbars>Objects to insert the toolbar).

The Text Object holds the actual text to be marked. Static text (text which will always remain the same within a layout) should be entered directly into this property. Any changes to this property will be directly reflected in the graphical view; the Text Object has the following properties assigned to it.

Font

The Font property is located in the Text Object window.

The font property is a drop down menu that lists all the currently installed fonts. All Windows True Type fonts can be marked either as an outline or filled. It is possible to create some text on the graphic view and step through the font list to preview each font until the desired font is displayed, use the up/down cursor keys to do this whilst the font list box is highlighted.

Is Filled

The Is Filled property is located in the Text Object window.

The Is Filled property defines whether text is marked as solid characters or simply outlined characters. The affect is one of denser (darker) characters. Simply select Yes or No from the drop down menu within the Is Filled edit field.

Maintain Ratio

The Maintain Ratio property is located in the Text Object window.

The Maintain Ratio property keeps the proportions between width within a specified text width window. Simply select Yes or No from the drop down menu within the Maintain Ratio edit field. If No is selected then the text will be re-sized to fill the specified text width window.

Text Alignment

The Text Alignment property is located in the Text Object window.

This property aligns the text left, right or centre in the specified width text box.
Simply select Centre, Left or Right from the drop down menu within the text alignment edit field.

**Is Inverted**

The Is Inverted property is located in the Text Object window. This property has the effect of ‘inverting’ the object. Used in conjunction with the vertical quiet zone property the text can be printed in the same colour as the background material using an inverse mark.

**Vertical Quiet Zone (mm)**

The Vertical Quiet Zone (mm) property is located in the Text Object window.

This property is used to create a blank space above and below an object to be marked (text, arc text, data matrix etc…) and is expressed in mm. It is used in conjunction with the Is Inverted property to maintain the image.

**Tweaks Properties**

The Tweaks Properties are located within the Text Object.

**Character Angle (deg)**

The Character Angle (deg) property is located in the Tweaks properties.

The Character Angle property is used to adjust the angle of the character ready for printing. The example below shows a character angle of 25 degrees.

![Character Angle Example](image.png)

**Spacing**

The Spacing property is located in the Tweaks properties.

The spacing property is used to add extra spacing between characters (default value is set to 1). The example below shows the spacing property set to 2; notice the increase in spacing between the characters and how the character width is reduced.

![Spacing Example](image.png)

**Compression**

The Compression property is located in the Tweaks properties.

The Compression property is used to ‘compress’ (horizontally) a piece of text while maintaining the preset height.

![Compression Example](image.png)
Shear
The Shear property is located in the Tweaks properties.

The X Shear property applies a horizontal shear effect to a piece of text. The example below shows a shear value of 0.5.

Position Properties
The Position properties are located within the Text Object.

X (mm)
The X (mm) property is located in the Position properties.

The X (mm) position property displays the current position of the object on the horizontal or X plane within the layout. It is possible to adjust this value directly by entering a known position into the X position edit box or by graphically moving the object by ‘dragging’ the mouse.

Y (mm)
The Y (mm) property is located in the Position properties.

The YPOS property displays the current position of the object on the vertical or Y plane within the marking layout. It is possible to adjust this value directly by entering a known position into the Y position edit box or by graphically moving the object by ‘dragging’ the mouse.

Width Property
The Width property is located in the Position properties.

The Width property displays the overall width of the text to be marked. This value should be changed to stretch or condense the text. The width property can also be changed by graphically dragging the mouse on the width handle of the text object.

Height Property
The Height property is located in the Position properties.

The Height property displays the character height of the text to be marked. This value should be changed to stretch or condense the height of the text. The height property can also be changed by graphically dragging the mouse on the height handle of the text object.

Angle (deg)
The Angel (deg) property is located in the Position properties.

The Angle property is used for setting the rotation angle of the object 0 – 360°. The object is rotated with respect to the objects origin. It is also possible to change this value graphically by dragging the mouse on the rotation handle of the object. In the example below the angle is set to 10°.
**Arc Text Properties**

The Arc Text Object is located in the Objects Tool Bar and in the Insert tab in the function bar drop down menu. (If the Objects Tool Bar cannot be viewed click on View>Toolbars>Objects to insert the toolbar). The Arc Text shares many of its properties with the Text object. The following properties are specific to the Arc text object.

The Arc property is used to form text around an arc.

**Inner Diameter (mm)**

The Inner Diameter (mm) property is located in the Arc Text Object window.

The Inner Diameter is used to define the inside diameter that the arc text will follow and is expressed in mm.

**Outer Diameter (mm)**

The Outer Diameter (mm) property is located in the Arc Text Object window.

The Outer Diameter is used to define the outside diameter that the arc text will follow and is expressed in mm.

**Offset (mm)**

The Offset (mm) property is located in the Arc Text Object window.

This property is used to position the arc text between the inner diameter and outer diameter boundaries. Clicking and dragging the graphic layout using the mouse will move the whole arc object.

**Align to Inner Diameter**

The Align to Inner Diameter property is located in the Arc Text window.

The Align to Inner Diameter property is used to align the arc text to the inner diameter (by selecting Yes from the drop down menu in the select field) or to the outer diameter (by selecting No from the drop down menu in the select field). An example of each is given below.
# The DataMatrix Object

The DataMatrix object encodes, marks and displays the ECC200 DataMatrix 2D coding standard. EtchMaster Professional supports many different formats of the DataMatrix code. An example of which is shown below.

The DataMatrix object has many similarities to the Text object. All of the following properties apply to the DataMatrix Object.

## Text

The Data Matrix Text object is located in the data matrix object window.

The Text property holds the text to be encoded and marked. Any changes to this property will be directly reflected in the graphical view. This can be seen when the matrix changes as new text is entered in the Text property.

### Static Text

Static text (Text which will always remain the same within a layout) should be entered directly into this property.

### Dynamic or Variable Text

Dynamic or Variable text such as serial numbers or time and date entries are also entered into the Text property but these entries are generated as commands using the Dynamic Text Generator dialog. See the Dynamic Text Generator section for further details.

## Size Property

The Size property is located in the data matrix object window.

The Size property is used to define the number of cells used and the shape of the matrix. DataMatrix codes can either be Square or Rectangular. The drop down menu lists the following matrix sizes:

- Square Best Fit, Rectangular Best Fit, 10x10, 12x12, 14x14, 16x16, 18x18, 20x20, 22x22, 24x24, 26x26, 32x32, 36x36, 40x40, 44x44, 48x48, 18x8, 32x8, 26x12, 32x12, 36x16, and 48x16.

Each variant of the matrix has a limit to the amount of information that can be encoded. For example the 10x10 matrix can only encode up to 3 ASCII characters, if this limit is exceeded the Matrix becomes a solid black square. To prevent this situation occurring, especially when using variable text, it is advisable to use either the Fit Square or Fit Rectangle options. These two options automatically ‘grow’ the matrix in size to ensure it is capable of encoding the required number of characters.

## Module Ratio

The Module Ratio property is located in the data matrix object window.

The Module Ratio property is used to define the size of the cells used to create the DataMatrix code. Very small code can suffer from print growth problems.
The datamatrix object

where cells can merge into adjacent cells, reducing this value can compensate
for it.

**Is Inverted**

The Is Inverted property is located in the Data Matrix Object window.

This property has the effect of ‘inverting’ the marking process. Instead of marking
the outline of the data matrix, the etcher will mark the background around the
data matrix. An example of each is shown below.

<table>
<thead>
<tr>
<th>Is Inverted</th>
<th>No</th>
<th>Is Inverted</th>
<th>Yes</th>
</tr>
</thead>
</table>

**Quiet Zone (mm)**

The Quiet Zone (mm) property is located in the Data Matrix Object window.

This property is used to create a blank space around an object to be marked (text, arc
text, data matrix etc…) and is expressed in mm. It is used in conjunction with the ‘Is
Inverted’ property to maintain the image.

**Position Properties**

**X (mm)**

The X (mm) property is located in the Position properties.

**Y (mm)**

The Y (mm) property is located in the Position properties.

**Width Property**

The Width property is located in the Position properties.

**Height Property**

The Height property is located in the Position properties.

**Maintain Ratio**

The Maintain Ratio property is located in the Position properties window.

The Maintain Ratio property keeps the proportions between cells within a specified
data matrix. Select Yes or No from the drop down menu within the Maintain Ratio
edit field.

**Auto Grow**

The Autogrow property is located in the Position properties window.

The Auto Grow property, when activated, allows the DataMatrix code to grow in
actual marking size when the number of cells increases due to additional data being
encoded. Turning this property off fixes the physical size of the code regardless of how many cells it contains.

**Module Width**

The Module Width property is located in the Data Matrix Position properties window.

The Module Width property is used to define the cell/module width.

**Module Height**

The Module Height property is located in the Data Matrix Position properties window.

The Module Height property is used to define the cell/module height.

**Angle (deg)**

The Angle (deg) property is located in the Data Matrix Position properties window.

The Angle property is used for setting the rotation angle of the object 0 – 360°. The object is rotated with respect to the objects origin. It is also possible to change this value graphically by dragging the mouse on the rotation handle of the object.
Barcode

The barcode object encodes, marks and displays a barcode ready for marking. The EtchMaster Professional software supports many different types of barcodes, these are selectable using the drop down menu in the barcode format window (see below).

Text

The Text Object is located in the Barcode Object window.

The barcode text object is used for directly entering the data to be held in the barcode. The Text property holds the text to be encoded and marked. Any changes to this property will be directly reflected in the graphical view. This can be seen when the barcode changes as new text is entered in the Text property.

Format

The Format Object is located in the Barcode Object window.

The Format property is used to define the type of barcode algorithm when creating barcodes. The 39 Standard barcode format is shown below. Others are available.

Use Check Digit

The Use Check Digit is located in the Barcode Object window.

The Use Check Digit enters a check digit into the barcode that indicates the start and finish of that barcode. This is particularly useful when reading the barcode with a barcode scanner since the scanner receives a definite reading of the barcode data.

Bar Width Ratio

The Bar Width Ratio is located in the Barcode Object window.

The Bar Width ratio defines the mark-space ratio of the barcode. The Bar Width Ratio is measured in mm and can be reduced to a spacing of 0.01mm. This value can be modified if there are print growth problems when marking.

Is Inverted

The Is Inverted property is located in the Barcode Object Window. This works the same as the Data Matrix 'Is Inverted' property,
**Quiet Zone (mm)**

The Quiet Zone (mm) property is located in the Bar Code Object window.

This property is used to create a blank space at each end of the barcode object to be marked and is expressed in mm. It is used in conjunction with the Is Inverted property to maintain the image.

**Position Properties**

The Position properties are located within the Barcode Object.

**X (mm)**

The X (mm) property is located in the Position properties.

**Y (mm)**

The Y (mm) property is located in the Position properties.

**Width Property**

The Width property is located in the Position properties.

**Height Property**

The Height property is located in the Position properties.

**Angle (deg)**

The Angle property is located in the Position properties.
The Imported Graphics File Object

The Imported Graphics File Object is used to allow graphical objects (HPGL logo’s and vector drawings) to be imported into EtchMaster Professional for laser marking. Complex drawings or logos can be imported from many drawing and CAD packages. The File formats supported by EtchMaster Professional are:

- HPGL 1&2 (*.plt)
- AutoCAD DXF Revision 12 (*.dxf)

To import a file click on the Graphics icon, this displays the vector-drawing object in the layout contents window, select the vector-drawing object then in the drawing tab either type in the path (if known) or click the search tab, to view the Open file window (shown below).

When the desired file is selected, Click Open and the object will be imported into the marking layout.

Note: When a layout is saved only the file path to the object is saved not the object itself. Always ensure that the imported graphics files remain at the locations pointed to within the marking layouts.

An Imported Graphics File Object has the following Properties available.

**Is Filled**

The Is Filled property is located within the Drawing property in the HPGL logo object.

This property fills the vector drawing in the same way the Is Filled property works within the text object.
Position Properties
The Position properties are located within the HPGL logo Object.

X (mm)
The X (mm) property is located in the Position properties.

Y (mm)
The Y (mm) property is located in the Position properties.

Width Property
The Width property is located in the Position properties.

Height Property
The Height property is located in the Position properties.

Maintain Ratio
The Maintain Ratio property is located in the Position properties.

Angle (deg)
The Angle property is located in the Position properties.
Saving and Opening Layouts

Once layouts have been created and markable objects have been created, the layout may be saved. To do this, either select Save from the File menu or click the Save button on the toolbar. If the filename has already been specified the file will be saved. If not, the File Save As dialog will be displayed.

Using the File Save As Dialog enter the desired filename and select Save. The Layout has now been saved.

To open layouts either select Open from the File menu or click on the open button on the toolbar. The File Open dialog will be displayed.

Select the desired layout and click the open button. The layout is then loaded.

Printing a Layout

When objects have been added to a layout, the Etch Layout toolbar button is enabled. Pressing this button or selecting Etch>Etching Dialog... from the main menu display loads the etching dialog.

The Etching Dialog is used to send layouts to the label printer and etch settings to the Pryor EtchMaster USB etching unit (if attached). To print a stencil simple click Print Layout. To send the settings to the Etching unit click the ‘Upload Settings to Etching Device’ button.

To close the Etching dialog click the X in the top right corner of the dialog.
Variables

Variables can be used within a layout for many reasons:

- Keeps all variable data in one place when editing the layout
- Allows variable data fields to be named to ease editing
- Allows the same data marked in multiple positions in the layout to be edited only once.
- Allows dynamic data such as time and date information to be marked automatically in the layout.
- Provides access to layout data within the vbscript interface.
- Provides mathematical functions for manipulating variable data. Such as serial numbers.

A variable can be added to the layout by clicking the toolbar button. This creates a Variables section within the Layout Contents area of the screen.

When the variable is selected a name and value can be assigned to it. The name is used to refer to the variable within the layout and the value is what actually gets marked when the variable is used within the layout.

The example above shows that the variable has been named ‘Part Number’ and its value is ‘FW123456’.

To mark this variable we use the [VAR:Name] command within the markable objects Text property. For example,

The text object above contains the text [VAR:Part Number]. This is a variable command which links the text object to the Part Number variable. As you can see by the graphics...
view the text to be marked is FW123456 which is the value of the Part Number variable.

Fixed text and other variables can be used within the same text / DataMatrix / barcode object to build a combination of data within the same markable object.

For Example if the following was entered into the above text object...

PART NO. [VAR:Part Number]  DATE. [MONTHDAY]/[MONTH]/[YEAR]

The text marked would be.

PART NO. FW123456  DATE. 23/01/2004

### Time/Date Variables

The following Time/Date variables may be used within a layout.

- [SECOND]
- [MINUTE]
- [HOUR]
- [AMPMTEXT]
- [AMPM]
- [WEEKDAYTEXT]
- [WEEKDAYTEXTABB]
- [WEEKDAY]
- [WEEK]
- [MONTHTEXT]
- [MONTH]
- [MONTHDAY]
- [YEARDAY]
- [YEAR]
- [CODE([HOUR]):ABCDEFGHIJKLMNOPQRSTUVWXYZ]